Rocket League Matchmaking Outage

Incident Report for Epic Games Public

Resolved

Matchmaking issues have been resolved. Players should now be able to queue into matches normally.
Posted May 12, 2026 - 01:01 UTC

Identified

We're working to resolve an issue where players are unable to matchmake. We'll provide another update when this is fixed.
Posted May 12, 2026 - 00:05 UTC
This incident affected: Rocket League (Matchmaking).