Epic Online Services experiencing issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Apr 09, 2023 - 03:22 UTC
Investigating
We are currently experiencing an issue that causes EOS Stats, EOS Achievements, and EOS leaderboards data to be delayed.
Posted Apr 06, 2023 - 20:46 UTC
This incident affected: Epic Online Services (Achievements, Leaderboards, Lobbies, Sessions, Epic Games Store Ecommerce, Stats).