Login and Purchasing Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted May 15, 2020 - 03:09 UTC
Update
We are continuing to investigate this issue.
Posted May 15, 2020 - 03:08 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 23:59 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 23:57 UTC
Update
We are continuing to address these issues.
Posted May 14, 2020 - 17:43 UTC
Update
We are continuing to address these issues.
Posted May 14, 2020 - 17:38 UTC
Update
We are continuing to address these issues.
Posted May 14, 2020 - 17:37 UTC
Update
We're aware that logins and purchases are additionally impacted on iOS and Android. We're actively working to resolve login and purchasing issues on all affected platforms and will continue to keep you updated.
Posted May 14, 2020 - 17:34 UTC
Investigating
We're investigating issues on PC and Mac that may impact Launcher logins and purchases.
We'll provide an update as we have more info.
Posted May 14, 2020 - 15:25 UTC
This incident affected: Battle Breakers (Login, Item Shop), Fortnite (Login, Item Shop), and Epic Games Store.