Rocket League - Friends not appearing on Friends List 6/7/2022
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 07, 2022 - 23:59 UTC
Investigating
We are currently investigating this issue.
Posted Jun 07, 2022 - 21:49 UTC
This incident affected: Rocket League Sideswipe (Parties, Friends, and Messaging) and Rocket League (Parties, Friends, and Messaging).