Epic Game Store Purchases Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 6 months ago. May 03, 2019 - 21:40 UTC
Identified
We're aware of an issue impacting the Epic Games Store resulting in recent purchases not reflecting after a successful transaction. We're actively investigation and will provide updates as we work towards resolution.
Posted 6 months ago. May 03, 2019 - 18:47 UTC
This incident affected: Epic Games store.