Rocket League matchmaking and general connection issues
Incident Report for Epic Games Public
Resolved
Matchmaking and general connection issues in Rocket League have been resolved.
Posted Feb 05, 2025 - 17:59 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2025 - 17:23 UTC
Investigating
We are aware players may be experiencing matchmaking or general connection issues in Rocket League.
Posted Feb 05, 2025 - 17:17 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging, Voice Chat).