x
Get the
Atom Feed
or
RSS Feed
.
Achievements not displaying in the Social Overlay
Incident Report for
Epic Games Public
Resolved
This incident has been resolved.
Posted
Feb
03
,
2022
-
23:20
UTC
Investigating
We are currently investigating this issue.
Posted
Feb
03
,
2022
-
23:05
UTC
This incident affected: Epic Online Services (Achievements).
×
Subscribe to Incident
Subscribe to updates for
Achievements not displaying in the Social Overlay
via . You'll receive .