Service Issues - Cube Disappearance
Incident Report for Epic Games Public
Resolved
The issues following the cube disappearance appear to have subsided.
Posted 8 days ago. Nov 04, 2018 - 19:36 UTC
Investigating
We're investigating several issues with Fortnite following the disappearance of a mysterious cube from the game. Please stand by.
Posted 8 days ago. Nov 04, 2018 - 18:45 UTC
This incident affected: Fortnite (Game Services, Login, Parties, Friends, and Messaging, Matchmaking).