Error 500 on Epic Games Store

Incident Report for Epic Games Public

Resolved

This issue has been resolved.
Posted Jan 25, 2020 - 14:11 UTC

Update

We are continuing to investigate this issue.
Posted Jan 25, 2020 - 14:10 UTC

Update

We are continuing to investigate this issue.
Posted Jan 25, 2020 - 13:54 UTC

Update

We are continuing to investigate this issue.
Posted Jan 25, 2020 - 13:54 UTC

Update

We are continuing to investigate this issue.
Posted Jan 25, 2020 - 13:52 UTC

Investigating

We are currently investigating this issue.
Posted Jan 25, 2020 - 13:51 UTC
This incident affected: Epic Games Store (Login), Fortnite (Login), and Login.