Epic Online Services: Player Reports
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 13:06 UTC
Investigating
We're aware of an issue affecting the EOS Player Reports Service and are actively investigating.
Posted Aug 27, 2024 - 09:41 UTC
This incident affected: Epic Online Services (Player Reports).