EGS High Traffic Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Dec 17, 2021 - 00:08 UTC
Investigating
We are currently experiencing high traffic on the Epic Games Store, and are aware that users may be encountering slow loading times, errors at checkout, or are unable to access the site and Launcher.
We are actively investigating and working to scale. Thanks for your patience!
Posted Dec 16, 2021 - 16:43 UTC
This incident affected: Epic Games Store (Login, Download/Installation, Purchasing/Refunding, Store Browsing) and Fortnite (Item Shop).