Account Service Issue
Incident Report for Epic Games Public
Resolved
The Account Services issues are fully resolved.
Posted Mar 14, 2018 - 21:23 UTC
Monitoring
Issues regarding Account Services appear to be resolved. We are monitoring for any fallout.
Posted Mar 14, 2018 - 20:34 UTC
Investigating
We've received reports of login and social connection issues, we're currently investigating.
Posted Mar 14, 2018 - 18:53 UTC