Fortnite Battle Royale: Operation: Dropzone Issues
Incident Report for Epic Games Public
Resolved
The issues with Operation: Dropzone have been resolved.
Posted Mar 18, 2020 - 21:34 UTC
Investigating
We are currently investigating issues with Operation: Dropzone and will provide an update when we have more information.
Posted Mar 18, 2020 - 21:22 UTC
This incident affected: Fortnite (Game Services).