Fortnite: Discover Loading Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Jul 31, 2023 - 15:35 UTC

Identified

We are aware of loading issues from some players in Discover. We will continue to investigate, and will update once the issue is fully resolved.
Posted Jul 30, 2023 - 15:27 UTC
This incident affected: Fortnite (Game Services).