Fortnite - CCU, Battle Pass and Player Rank not Updating Correctly
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jan 25, 2024 - 22:06 UTC
Investigating
We are currently investigating visual CCU numbers in game experiences, Battle Passes appearing blank for some players, and player ranks not appearing to update after a ranked game.
Posted Jan 25, 2024 - 19:24 UTC
This incident affected: Fortnite (Game Services, Stats and Leaderboards).