EOS Matchmaking Service Degradation

Incident Report for Epic Games Public

Resolved

The matchmaking issues with Epic Online Services have been resolved.
Posted Jun 12, 2025 - 18:19 UTC

Investigating

When trying to matchmake, players may experience increased errors and longer wait times. We're actively working to restore full stability to Epic Online Services.
Posted Jun 11, 2025 - 17:03 UTC
This incident affected: Epic Online Services (Lobbies, Sessions).