EOS Matchmaking Issue

Incident Report for Epic Games Public

Resolved

We’ve resolved the issue; matchmaking and lobby online services are restored. We’ll continue to monitor this to ensure no further disruptions occur.
Posted Mar 04, 2025 - 04:06 UTC

Investigating

We're investigating matchmaking and lobby failures with Epic Online Services and are working on a fix now.

We'll provide another update when we have more info, or once the issue is resolved.
Posted Mar 04, 2025 - 02:34 UTC
This incident affected: Epic Online Services (Lobbies, Matchmaking).