Emails for 2FA and for Resetting Password
Incident Report for Epic Games Public
Resolved
While working to address this issue, we've found that active accounts are largely unaffected. However, we will continue to address this issue for affected accounts so emails for 2FA and password resets are sent properly.
Posted May 08, 2020 - 20:53 UTC
Identified
We're aware of an issue involving some players currently not receiving emails for 2FA or for resetting their password. We're working to address this and will provide an update when this is resolved.

In the meantime, if you're not receiving emails for 2FA or for resetting your password, please check your email account's spam settings.
Posted May 05, 2020 - 16:23 UTC
This incident affected: Epic Online Services (Authentication).