epicgames.com - Accounts page outage
Incident Report for Epic Games Public
Resolved
This issue was resolved at 13:00 UTC
Posted 5 months ago. Jul 27, 2018 - 19:09 UTC
Identified
We have identified an issue with the accounts page for epicgames.com resulting in a 500 error and are actively working to clean this up. Thanks for your patience!
Posted 5 months ago. Jul 27, 2018 - 12:20 UTC
This incident affected: Fortnite (Website and Forums).