Rocket League - PsyNet Connection Disruption - 07/22/2021
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 09:13 UTC
Investigating
We are currently investigating this issue.
Posted Jul 22, 2021 - 07:04 UTC
This incident affected: Rocket League (Login, Website, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging).