Save the World Matchmaking Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 08, 2018 - 04:49 UTC
Monitoring
We've deployed a fix and are tracking recovery.
Posted 4 months ago. Jun 08, 2018 - 04:41 UTC
Identified
Root cause of the issue has been identified and a potential fix is underway for testing and validation.
Posted 4 months ago. Jun 08, 2018 - 03:49 UTC
Investigating
We're investigating an issue impacting matchmaking success and times for Save the World players.
Posted 4 months ago. Jun 08, 2018 - 03:08 UTC