Rocket League Matchmaking Disruption
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 18:05 UTC
Investigating
We are aware some players may be experiencing matchmaking or general connection issues in Rocket League. We're investigating and will provide an update once this is resolved.
Posted Jan 15, 2025 - 16:50 UTC
This incident affected: Rocket League (Matchmaking).