EOS Matchmaking/Lobby Disruption

Incident Report for Epic Games Public

Resolved

EOS Matchmaking and lobby services have been restored. We're continuing to monitor the situation to ensure service stability.
Posted Mar 06, 2025 - 12:02 UTC

Investigating

We're investigating the ongoing issues with matchmaking and lobbies on Epic Online Services and are working on a fix. We’ll provide another update once we have more details or when the issue is resolved.
Posted Mar 06, 2025 - 11:11 UTC
This incident affected: Epic Online Services (Lobbies).