Epic Online Services Developer Portal Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:46 UTC

Investigating

We're aware that the Developer Portal is still experiencing issues following the recent service provider outage. Our team is working to mitigate the problem and will provide an update once it's resolved.
Posted Oct 20, 2025 - 20:24 UTC
This incident affected: Epic Online Services (Developer Portal).