Rocket League Website Homepage is Unavailable

Incident Report for Epic Games Public

Resolved

We are continuing to investigate this issue.
Posted Feb 13, 2025 - 21:31 UTC

Update

We are continuing to investigate this issue.
Posted Feb 13, 2025 - 21:05 UTC

Investigating

We are currently investigating this issue.
Posted Feb 13, 2025 - 21:05 UTC
This incident affected: Rocket League (Website).