Incorrect Item Shop Refresh Timer
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 26 days ago. Apr 24, 2019 - 18:28 UTC
Identified
The issue has been identified and we are investigating a fix.
Posted about 1 month ago. Apr 18, 2019 - 13:12 UTC
Investigating
We've identified an issue that may cause the Item Shop timer to appear incorrect. This is a visual bug only. The Item Shop will refresh at 0000 UTC as usual. A fix will be implemented after the next item shop refresh.
Posted about 1 month ago. Apr 18, 2019 - 00:59 UTC
This incident affected: Fortnite (Item Shop).