Fortnite Battle Royale: Matchmaking Errors in NA-East Region
Incident Report for Epic Games Public
Resolved
The matchmaking errors in the NA-East region for Fortnite Battle Royale have been resolved.
Posted Mar 02, 2020 - 18:42 UTC
Investigating
We're currently investigating matchmaking errors in the NA-East region for Fortnite Battle Royale. We'll provide an update when these are resolved.
Posted Mar 02, 2020 - 17:50 UTC
This incident affected: Fortnite (Matchmaking).