EOS Developer Portal Analytics Not Visible

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 11:29 UTC

Investigating

We're currently investigating an issue where the Game Analytics graphs do not populate info in the EPOS DevPortal.
Posted Aug 14, 2025 - 08:27 UTC
This incident affected: Epic Online Services (Developer Portal).