Fortnite: Stuck at "Checking for Updates" Screen
Incident Report for Epic Games Public
Resolved
The issue with the "Checking for Updates..." screen has been resolved. Players are again able to log in.
Posted Aug 07, 2021 - 00:07 UTC
Investigating
Players are unable to log into Fortnite at this time. This is due to being stuck at the "Checking for Updates" screen.
Posted Aug 06, 2021 - 23:33 UTC
This incident affected: Fortnite (Login).