Rocket League: Matchmaking Partial Outage - 4/5/2023
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 00:31 UTC
Investigating
We are aware some players are not finding matches, or are experiencing long queue times. We are investigating the issue.
Posted Apr 06, 2023 - 00:18 UTC
This incident affected: Rocket League (Matchmaking).