x
Get the
Atom Feed
or
RSS Feed
.
Login Issues
Incident Report for
Epic Games Public
Resolved
We have resolved the login issues, and players are now able to log in to Epic Games services again.
Posted
Dec
25
,
2022
-
19:33
UTC
Investigating
We are currently investigating this issue.
Posted
Dec
25
,
2022
-
17:18
UTC
This incident affected: Epic Games Store (Login), Fall Guys (Login), Rocket League (Login), and Fortnite (Login).
×
Subscribe to Incident
Subscribe to updates for
Login Issues
via . You'll receive .