Fortnite, Rocket League, Fall Guys, and Epic Online Services log-ins and game services are back online now, thanks for your patience. We'll continue to monitor services health to ensure everything continues to operate as normal.
Posted Dec 25, 2025 - 05:24 UTC
Update
We're still working on bringing Fortnite, Rocket League, Fall Guys, and Epic Online Services back online and restoring matchmaking to normal. Players currently logged in may see themselves kicked from the game while work to bring services back online.
Posted Dec 25, 2025 - 03:04 UTC
Investigating
We are investigating login issues impacting Fortnite, Rocket League, Fall Guys, and Epic Online Services. We are working on a fix ASAP and will share an update once this has been resolved.
Posted Dec 25, 2025 - 02:01 UTC
This incident affected: Rocket League (Login, Matchmaking), Fall Guys (Login), Epic Online Services (Epic Account Services - Authentication, Game Services - Authentication), and Fortnite (Login, Matchmaking).