Player Support Portal Maintenance
Incident Report for Epic Games Public
Resolved
Thanks for your patience, our Player Support services are back online.
Posted Mar 13, 2020 - 23:05 UTC
Identified
Our Player Support portal is currently undergoing maintenance, during this time support ticket responses and deletion requests may be delayed and self-service deletion requests may be unavailable.

To delete your account, please contact player support here: https://epicgames.helpshift.com/a/epic-accounts/?contact=1
Posted Mar 13, 2020 - 22:14 UTC
This incident affected: Battle Breakers (Website) and Fortnite (Website).