Fortnite - Item Shop Degradation
Incident Report for Epic Games Public
Resolved
Offers in the Item Shop have returned.
Posted Feb 22, 2024 - 02:01 UTC
Investigating
We are aware of an issue with Item Shop offers not appearing and are currently investigating.
Posted Feb 22, 2024 - 00:39 UTC
This incident affected: Fortnite (Item Shop).