Delayed Password Reset & MFA Notifications
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 21:07 UTC
Investigating
We're investigating an issue that's causing delays for notifications of password resets and multi-factor authentication for Fortnite and the Epic Games Launcher.
Posted Sep 30, 2020 - 17:36 UTC
This incident affected: Epic Online Services (Authentication).