Xbox Crashes
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 27, 2018 - 23:18 UTC
Investigating
We are investigating an increase in crashes on Xbox.
Posted 22 days ago. Sep 27, 2018 - 11:04 UTC