Log in Issues
Incident Report for Epic Games Public
Resolved
We've successfully resolved the log in issues that players were experiencing! Thank you for your patience.
Posted 2 months ago. Mar 15, 2019 - 14:25 UTC
Investigating
We're aware that players are having issues with logins. We're currently working on a fix.
Posted 2 months ago. Mar 15, 2019 - 13:52 UTC
This incident affected: Fortnite (Login).