RocketLeague.com is Down
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 17:54 UTC
Investigating
RocketLeague.com is currently 504ing, we are investigating the issue.
Posted Mar 06, 2024 - 16:46 UTC
This incident affected: Rocket League (Website).