Email Deliverability Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 22:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2021 - 18:47 UTC
Investigating
We're aware of an issue preventing players from receiving emails related to registration, 2FA, and Nitro codes.

We're working to address this and will provide an update when the issue is resolved.
Posted Jun 10, 2021 - 18:06 UTC