Epic Games Store achievements not received
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 15:52 UTC
Investigating
We are aware of an issue where players may not receive Epic Games Store achievements. We are actively investigating and will update this thread once this issue has been fixed.
Posted Jan 22, 2025 - 08:19 UTC
This incident affected: Epic Games Store (Achievements).