x
Get the
Atom Feed
or
RSS Feed
.
Metahuman Creator Sign-up Issue
Incident Report for
Epic Games Public
Resolved
This issue is now resolved and users are able to sign up for Metahuman Creator without error.
Posted
Apr
15
,
2021
-
20:42
UTC
Investigating
We're investigating an error displayed when signing up for Metahuman Creator and will provide an update when issue with form submission is resolved.
Posted
Apr
14
,
2021
-
17:04
UTC
This incident affected: MetaHuman Creator.
×
Subscribe to Incident
Subscribe to updates for
Metahuman Creator Sign-up Issue
via . You'll receive .