Epic Online Services Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 19:23 UTC
Investigating
We are currently investigating this issue.
Posted Sep 28, 2021 - 18:16 UTC
This incident affected: Epic Online Services (Authentication).