Impossible to launch games from the Epic Games Launcher
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 19:53 UTC
Investigating
We are currently investigating this issue.
Posted Jun 15, 2020 - 17:58 UTC
This incident affected: Epic Games Store (Login).