x
Get the
Atom Feed
or
RSS Feed
.
Rocket League - Matchmaking
Incident Report for
Epic Games Public
Resolved
This incident has been resolved.
Posted
Jan
21
,
2021
-
05:50
UTC
Monitoring
Matchmaking services are recovering but some may still experience delays finding matches.
Posted
Jan
21
,
2021
-
03:16
UTC
Investigating
Players on all platforms may experience issues trying to find a match
Posted
Jan
21
,
2021
-
02:58
UTC
This incident affected: Rocket League (Matchmaking).
×
Subscribe to Incident
Subscribe to updates for
Rocket League - Matchmaking
via . You'll receive .