Issues installing/launching Star Wars Jedi: Fallen Order
Incident Report for Epic Games Public
Resolved
A fix has been implemented that resolves the issue. Please exit and restart the Epic Games launcher. You should now be able to install/launch Star Wars Jedi: Fallen Order.
Posted Sep 15, 2020 - 18:49 UTC
Investigating
We are currently investigating an issue with installing/launching Star Wars Jedi: Fallen Order. Stay tuned for updates.
Posted Sep 15, 2020 - 17:27 UTC
This incident affected: Epic Games Store (Login).