EOS Login Issues - Epic Games Store, Fortnite, Rocket League, Fall Guys, Developer Portal

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 20:38 UTC

Update

We are continuing to investigate this issue.
Posted Nov 26, 2025 - 18:56 UTC

Update

We are continuing to investigate this issue.
Posted Nov 26, 2025 - 18:14 UTC

Update

We are continuing to investigate this issue.
Posted Nov 26, 2025 - 18:01 UTC

Investigating

We’re aware of players being unable to login to Epic Games Store, Fortnite, Rocket League, Fall Guys and Developer Portal.
Our team is investigating the issue and we'll follow up once the issue has been resolved.
Posted Nov 26, 2025 - 17:54 UTC
This incident affected: Epic Games Store (Login), Rocket League (Login), Rocket League Sideswipe (Login), Fall Guys (Login), Epic Online Services (Epic Account Services - Authentication, Game Services - Authentication, Developer Portal), Fortnite (Login), and ArtStation, Fab, Quixel, Sketchfab.