EGS Coupons Issue
Incident Report for Epic Games Public
Resolved
This issue is resolved and Coupons should be successfully redeeming on the Epic Games Store at checkout.

Thanks for your patience.
Posted Aug 27, 2020 - 01:54 UTC
Investigating
We're investigating an issue that is preventing some players from redeeming their Coupons on the Epic Games Store.

We'll provide an update when this is resolved.
Posted Aug 26, 2020 - 22:43 UTC
This incident affected: Epic Games Store (Login).