Rocket League Sideswipe Scheduled Downtime
Incident Report for Epic Games Public
Resolved
The scheduled maintenance has been completed.
Posted May 18, 2023 - 03:43 UTC
Monitoring
Rocket League Sideswipe is undergoing scheduled maintenance. This downtime is expected to last up to two hours.
Posted May 18, 2023 - 02:00 UTC
This incident affected: Rocket League Sideswipe (Login, Website, Game Services, Matchmaking, Stats & Leaderboards, Item Shop, Parties, Friends, and Messaging).