Players are unable to receive emails for registration, password reset, and 2FA
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Oct 03, 2021 - 09:16 UTC
Investigating
We are currently investigating this issue.
Posted Oct 03, 2021 - 05:41 UTC
This incident affected: Epic Games Store (Login), Rocket League (Login), Fortnite (Login), and Battle Breakers (Login).