Purchase issues in Epic Games Store
Incident Report for Epic Games Public
Resolved
Epic Games Store purchasing was broken for several hours earlier today on PC/Web/Android/iOS and it's now fixed.

If you received an error message indicating your account was blocked from purchasing, it was mistaken. Impacted accounts are now fine, and we apologize for the error.
Posted Dec 27, 2024 - 18:31 UTC
Investigating
We are investigating an issue where players are unable to complete a purchase in the Epic Games Store.
Posted Dec 27, 2024 - 16:59 UTC
This incident affected: Epic Games Store (Purchasing/Refunding).